Started almost 3 years agoAugust 21, 2023Lasted about 2 hours7:389:30 AMUTC
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Monitoring
UTC
Monitoring
UTC
We implemented the fix and the system is back to operational for now. We'll continue monitoring.
Investigating
UTC
Investigating
UTC
Our credit check system experiences an issue which can impact UK and SE clients. We will let you know as soon as the issue will be resolved.
• Order Intents & Orders are partially impacted by this incident