Two - Company search is failing in Norway for some use cases – Incident details

Company search is failing in Norway for some use cases

Resolved
Partial outage 50 %
Started 2 months agoLasted 1 day

Affected

Nordics

Partial outage from 9:25 AM to 10:35 AM, Degraded performance from 10:35 AM to 12:00 PM

Updates
  • Postmortem
    Postmortem

    This incident arose due to two root causes: (1) a gap in automated testing resulting in a bug escaping to production at 10:25am UK on 28 August; and (2) a monitoring misconfiguration which masked ongoing out-of-memory restart events and which reduced visibility of the impact of the bug. We have addressed these issues by reviewing monitoring configurations to ensure all services are correctly covered, and by both improving test coverage and ensuring that test coverage is monitored on an ongoing basis. We extend our apologies to customers for the impact caused by this incident.

  • Resolved
    Resolved

    The remaining intermittent errors have now been resolved. This incident is now closed.

  • Monitoring
    Monitoring

    Normal service has been restored. We are however aware of continuing low-frequency intermittent errors and are working to remediate them.

  • Identified
    Identified
    This prevents onboarding and ordering for new customers, and for guest checkout, if the merchant integration relies on parameter company\_type\_\_ne. Ordering against existing trade account is unaffected. We have identified the root cause and are working on a fix.