Two - Upstream data provider outage – Incident details
All systems operational
Upstream data provider outage
Resolved
Major outage
Started 2 days agoAugust 26, 2026Lasted about 1 hourAugust 26, 202611:30 AM12:45 PMUTC
Updates
Resolved
UTC
Resolved
UTC
The issue affecting credit checks has been resolved. All services are now operating normally.
Monitoring
UTC
Monitoring
UTC
Upstream data provider problems are resolved and we are seeing no new errors
Investigating
UTC
Investigating
UTC
We are having upstream issues with one of our data providers, resulting in credit reports and orders for brand new buyers failing. Existing buyers are not affected