Two - Invoices and statements download issue – Incident details

Experiencing partially degraded performance

Invoices and statements download issue

Resolved
Degraded performance
Started over 1 year agoLasted about 3 hours

Affected

Portals

Degraded performance from 12:02 PM to 2:42 PM

Merchant Portal

Degraded performance from 12:02 PM to 2:42 PM

Checkout API

Degraded performance from 12:02 PM to 2:42 PM

Norway

Degraded performance from 12:02 PM to 2:42 PM

United Kingdom

Degraded performance from 12:02 PM to 2:42 PM

Sweden

Degraded performance from 12:02 PM to 2:42 PM

Updates
  • Resolved
    Resolved

    We identified the root cause of the problem down to CDN of our object storage provider. We have implement a workaround to proxy the generated invoices, credit notes and statements through our server until the CDN is back online.

  • Investigating
    Investigating

    Our customers may be encountering difficulties downloading invoices and statements via the merchant portal. We are actively working to replicate the issue, identify the root cause, and implement a prompt resolution.