Two - Credit checks and order placements unavailable for new buyers – Incident details

Credit checks and order placements unavailable for new buyers

Resolved
Major outage
Started 19 days agoLasted about 9 hours
Updates
  • Resolved
    Resolved

    We have confirmed normal operation. Thank you to all of our partners for your patience during this incident.

  • Monitoring
    Monitoring

    The issue has been resolved. We are monitoring to confirm return to normal service.

  • Update
    Update

    We have confirmed that the UK is not affected by this incident.

  • Identified
    Identified
    An issue with an account at a 3rd party service provider has been identified and is being rectified. Resolution is expected by 9am UK.
  • Investigating
    Investigating
    We are currently investigating this incident.